Line 1:
Line 1:
+
==WIP: OSRegisterSystemModeCallback==
+
It's a function!
+
<syntaxhighlight lang="C">int OSRegisterSystemModeCallback(int unk, int ident, void(*callback)(int unk, int unk2));</syntaxhighlight>
+
Looks like coreinit keeps a table of "sytem mode callbacks", each with its own struct. Each one needs a unique "ident". Returns 1 if adding the callback worked, 0 otherwise. Not entirely sure what the callbacks actually do. Implementation from vpadbase.rpl calls it with (0x96, 4, &callback). Looking for more info on this! [[User:QuarkTheAwesome|Ash]] ([[User talk:QuarkTheAwesome|talk]]) 02:16, 3 May 2017 (CEST)
+
+
==cpuRatio confusion==
The name "cpuRatio" for the field that was added to the OSSystemInfo structure seems a bit unclear to me. Surely we can find a better name, or add a comment about it? [[User:Neobrain|Neobrain]] ([[User talk:Neobrain|talk]]) 10:29, 9 June 2016 (CEST)
The name "cpuRatio" for the field that was added to the OSSystemInfo structure seems a bit unclear to me. Surely we can find a better name, or add a comment about it? [[User:Neobrain|Neobrain]] ([[User talk:Neobrain|talk]]) 10:29, 9 June 2016 (CEST)
+
==bool vs int==
About the "Boot" section BullyWiiPlaza just added, i think all these functions are returning boolean since false is 0 and true is 1, so do someone think i have to change it to bool ? --[[User:NexoCube|NexoCube]] ([[User talk:NexoCube|talk]]) 22:01, 14 August 2016 (CEST)
About the "Boot" section BullyWiiPlaza just added, i think all these functions are returning boolean since false is 0 and true is 1, so do someone think i have to change it to bool ? --[[User:NexoCube|NexoCube]] ([[User talk:NexoCube|talk]]) 22:01, 14 August 2016 (CEST)